"Something went wrong. Please try again" message when adding postage in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

The message "Something went wrong. Please try again" when adding postage means that the payment method for adding postage was declined.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When adding postage, the message "Something went wrong. Please try again" appears.

Cause

The payment method for adding postage was declined.

Resolution

If the balance in your is less than the amount you are trying to add, add funds to your .

If the available credit in your is less than the amount you are trying to add, make a payment on your , or request a Purchase Power credit limit increase through Pitney Bowes.

If using a credit card and it needs to be changed, see Changing your postage payment method.

 

UPDATED: December 12, 2023