Resolve stuck on "Initializing" on the DM100i-DM225
Learn how to resolve the DM100i, DM125, DM200L and DM225 being stuck on "Initializing".
Products affected: DM100®i, DM125™, DM200L™, DM225™
Issue
The meter will not progress past the "Initializing" screen.
Cause
The meter has experienced an internal error that is preventing normal operation.
Resolution
To resolve this issue, restart the meter:
- Unplug the power cord.
- Wait one to three minutes.
- Plug the power cord back in, ensuring that it is plugged directly into a wall outlet.
UPDATED: August 14, 2021