"Subscription at Risk - Take Action Now" message in PitneyShip

If you see the message "Subscription at Risk - Take Action Now", your payment credit card needs to be updated.

Products affected: PitneyShip®

Issue

The message "Subscription at Risk - Take Action Now" appears,

Cause

Your subscription credit card payment failed. It may be expired, or something else may have gone wrong.

Resolution

Update your credit card details or add a new credit card.

Solution 1: Update your credit card details

  1. Select Update card details next to the card that needs to be updated.
  2. Update the card details as needed, then click Submit. The payment will be retried right away.

If that does not work, try switching a different card.

Solution 2: Switch to a different credit card

If you already have another card saved in your account, try switching to it. If you do not, go to the next solution.

  1. Select Switch to this card. The payment will be retried right away.

If the payment is successful, this card will be set as your primary payment method.

If that does not work, try adding a new card.

Solution 3: Add a new credit card

  1. Select Add New Card.
  2. Enter the card details, then click Submit. The payment will be retried right away.

If the payment is successful, this card will be set as your primary payment method.

The features and options you see may vary depending upon your role and subscription. If you have any questions regarding your permissions, please contact your administrator.

UPDATED: July 29, 2025