Unable to save package while receiving, editing, or delivering packages in PitneyTrack Inbound or PitneyTrack Enterprise

Ensure you complete all the required fields or clear your cache if you cannot save while receiving, editing or delivering a package.

Products affected: PitneyTrack® Inbound, PitneyTrack® Enterprise

Issue

You cannot save the package as the Save button is greyed out while receiving, editing, or delivering packages.

Cause

  • 1 or more of the Required fields in the form is empty.
  • Browser cache issue.

Resolution

  1. Ensure you complete all the required fields.
  2. Check the Input Field Options:
    1. Select Settings.
    2. Select Input Field Options under Receiving.
    3. Check all the options within Receiving, Edit, Delivery and Pouch.
    4. Enable or disable a field as required by checking or unchecking the required box.
    5. Save your changes:
      • If you are using PitneyTrack Inbound or PitneyTrack Asset, select the Update Settings button at the top to save your changes.
      • If you are using PitneyTrack Enterprise, select Save Settings, select the sites where you want to apply your changes to and select Update # Site(s) or Update All Sites.
  3. You can now receive, edit, or deliver the package.

UPDATED: July 23, 2025