"Transaction declined" message on the SendPro Mailstation

Learn how to resolve the "Transaction declined" error message you receive when trying to add postage.

Products affected: SendPro® Mailstation, SendPro® Mailstation LITE (HZ0L)

Issue

The "Transaction declined" message appears when you try to add postage.

Cause

Your credit card was declined by the credit card provider. It may be invalid or expired.

Resolution

Update your payment method in PitneyShip.

  1. Sign in to PitneyShip.
  2. Select Settings > Payment Methods.
  3. Expand the credit card you wish to update.
  4. Select Update Credit Card Info.
  5. Update the information as needed and click Submit.

If the issue persists, contact your credit card provider for further assistance.

UPDATED: June 16, 2025