DeviceHub disconnects and must be restarted to reconnect in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
DeviceHub may disconnect frequently if the computer goes into standby or sleep mode. You can schedule a Windows task to automatically restart it.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
DeviceHub disconnects frequently and must be restarted in order to reestablish the connection.
Cause
DeviceHub is stopping because the computer is going into standby or sleep mode.
Resolution
Use the Windows Task Scheduler to restart DeviceHub at a scheduled time.
- In the Windows search box, type Task Scheduler and select Task Scheduler.
- On the left side, select Task Scheduler Library.
- On the right side, select Create Task….
- Select the General tab.
- In the Name field, enter a name for the task (for example, Restart DeviceHub).
- Under Security options, if the account used to sign in to Windows is not an administrator, select Change User or Group and select an administrator account.
- Select the Triggers tab.
- Select the New button.
- Select how often and when you want the task to run to restart the DeviceHub service.
- Select OK.
- Select the Actions tab.
- Select the New button.
- In the Action field, select Start a program.
- In the Program/script field, enter: taskkill
- In the Add arguments field, enter: /f /im “DeviceHub.exe”
- Select OK.
- Select the New button.
- In the Action field, select Start a program.
- In the Program/script field, click Browse and select the DeviceHub executable. For example, C:\ProgramData\PB\devicehub\DeviceHub_v1\DeviceHub.exe.
- Select OK.
- (Optional) Select the Conditions tab and set any conditions you wish.
- (Optional) Select the Setting tab and select any settings you wish.
- Select OK.
The task will run at the specified time and will stop and then restart DeviceHub.
UPDATED: December 12, 2024