Error "Failed to refresh OAuth token with the carrier: bad request" appears when shipping using carrier UPS API in SendPro Enterprise
Learn how to resolve the error message "Failed to refresh OAuth token with the carrier: bad request" when shipping using carrier UPS API in SendPro Enterprise.
Products affected: SendPro® Enterprise
Issue
You have completed the UPS OAuth process and the error "Failed to refresh OAuth token with the carrier: bad request"appears when attempting to ship using carrier UPS API.
Cause
The UPS OAuth token is invalid.
Resolution
- Open the UPS API OAuth Setup App. in SendPro Enterprise
- Select Edit beside the required UPS Account Group.
- Click Get Token and enter the UPS.com profile username and password. If successful, close the pop-up success message.
- Click Reload.
- Click Save and Close.
If the issue is not resolved, contact UPS Support at 1-800-742-5877 or https://www.ups.com/us/en/support/contact-us.page.
UPDATED: July 08, 2024