"ParseErrorResponse: The DeviceHub [...] is OFFLINE!" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
Issue
The error message "devicehub.Print: ParseErrorResponse: <validation_error> The DeviceHub [...] is OFFLINE! The label was generated but unable to print. Try printing again or request refund from" appears when attempting to print stamps or shipping labels in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise.
Cause
The printer or DeviceHub is offline and not responding.
Resolution
- Solution 1: Make sure DeviceHub is installed
- Solution 2: Verify that DeviceHub is running
- Solution 3: Make sure DeviceHub is updated
- Solution 4: Reconnect DeviceHub
- Solution 5: Activate DeviceHub
- Solution 6: Make sure that your printer is installed, connected, and online
Solution 1: Make sure that DeviceHub is installed
To install DeviceHub, see Installing DeviceHub.
Solution 2: Verify that DeviceHub is running
There should be a DeviceHub icon in the Windows system tray (small icons near the clock) or the Mac OS menu bar to show that it is running.
If this icon is missing, find DeviceHub in your programs list and restart it. Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 3: Make sure DeviceHub is updated
Check for DeviceHub updates. See Updating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise.
Solution 4: Reconnect DeviceHub
- Find the DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar.
- Right-click on the DeviceHub icon and choose Reconnect.
- Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.
Solution 5: Activate DeviceHub
- Select Settings > My Devices.
- Select Activate DeviceHub.
- Click the Activate button in the pop-up window.
- If successful, a new browser tab window will open with a "DeviceHub registered successfully!" message.
- Close the new browser tab and select Settings > My Devices.
- If your printers are still not displayed, click the Refresh button on the My Devices page.
Solution 6: Make sure that your printer is installed, connected, and online
- Select Settings > My Devices.
- Verify that your printer shows an Online or Idle status.
- If the printer is still not listed, or the printer status is Offline or Other, check the following:
- Make sure that the printer is installed on the computer. If it is not, visit the manufacturer's website to download and install the latest print driver.
- On Windows, go to Settings > Devices > Printers and make sure that your printer is present and online.
- On Mac, go to Apple menu > System Settings > Printers & Scanners and make sure that your printer is present and online.
- Verify that the printer is turned on and awake.
- Verify that the printer is correctly connected to the computer.
- Make sure that the printer is installed on the computer. If it is not, visit the manufacturer's website to download and install the latest print driver.
- Once the printer is connected and online, try to print again.
If you need further assistance, please chat with us.
UPDATED: May 09, 2024