"3009: Address validation failed" message when creating a DHL shipping label in PitneyShip Pro or PitneyShip Enterprise
The message "3009: Address validation failed" occurs when the recipient address does not meet DHL's address requirements.
Products affected: PitneyShip® Pro, PitneyShip® Enterprise
Issue
When processing a DHL shipping label, the message, "3009: Address validation failed." appears.
Cause
The recipient address does not meet DHL's address requirements.
Resolution
Make sure that the recipient address is entered correctly and meets DHL's requirements. You can check the DHL website to verify the correct format of the address.
UPDATED: May 07, 2024