"devicehub.pollPrintJobStatus: The DeviceHub is not responding, it is either OFFLINE or the network connection is slow!" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

The message "devicehub.pollPrintJobStatus: The DeviceHub is not responding, it is either OFFLINE or the network connection is slow!" means that DeviceHub may be offline, need to be updated, or the connection needs to be refreshed.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When printing shipping labels or stamps, the message "devicehub.pollPrintJobStatus: The DeviceHub is not responding, it is either OFFLINE or the network connection is slow" appears.

Cause

DeviceHub may be offline, need to be updated to the latest version, or the connection needs to be refreshed.

Resolution

Solution 1: Make sure that DeviceHub is installed

To install DeviceHub, see the instructions for your product:

Solution 2: Verify that DeviceHub is running

There should be a DeviceHub icon in the Windows system tray (small icons near the clock) or Mac OS menu bar to show that it is running.
[[[Undefined variable SendPro-SaaS-Variables.ProductName - DeviceHub]]] icon

If this icon is missing, find DeviceHub in your programs list and restart it.

Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.

Solution 3: Verify that DeviceHub is updated to the latest version

For instructions, see:

Solution 4: Make sure that your printer is installed, connected, and online

  1. In PitneyShip, PitneyShip Pro, or PitneyShip Enterprise, go to Settings > My Devices.
  2. Verify that the printer shows an Online or Idle status.
  3. If the printer is not listed, or the status is Offline or Other, check the following:
    • Make sure that the printer is installed on the computer.
    • In Windows, go to Settings > Devices > Printers and make sure that the printer is present and online.
    • On Mac, go to Apple menu > System Settings > Printers & Scanners and make sure that the printer is present and online.
    • Verify that the printer is turned on and awake.
    • Verify that the printer is on and is connected correctly to the computer.
  4. Once the printer is connected and online, try to print again.

Solution 5: Reconnect DeviceHub

  1. Find the DeviceHub icon in Windows system tray (small icons near the clock) or Mac OS menu bar.
  2. Right-click on the DeviceHub icon and choose Reconnect.
    DeviceHub icon
  3. Once the DeviceHub icon appears, hover your mouse over the icon to see the connection status and wait until it shows an Online status.

UPDATED: April 25, 2024