"Pick up time is invalid" message when scheduling a UPS On Call Pickup in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

If the message "Pickup time is invalid. Select a different time slot." appears when scheduling a UPS On Call Pickup, a different pick up time needs to be selected.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When scheduling a UPS On-Call pickup, the error message "Pickup time is invalid. Select a different time slot" appears.

Cause

The selected time frame for the UPS service or pickup address is invalid.

Resolution

Under Pickup Date and Time, select a different From Time and To Time or the next calendar day for your Pickup Date.

If the issue persists, please chat with us.

 

UPDATED: April 06, 2024