"Incomplete commodity description" message when shipping FedEx International in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

Learn how to resolve the "Incomplete commodity description" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise

Issue

When shipping an international FedEx package, the message "There was an error generating your label. Shipping Item must have a Description. {2039} Incomplete commodity description 1" is displayed. Similar messages may be displayed for additional customs items ("Incomplete commodity description 2", "Incomplete commodity description 3", etc.).

Cause

FedEx did not accept the commodity description of Items under International Shipment Details.

Resolution

  1. Under the International Shipment Details, click the pencil icon to edit the items of your shipment.
  2. Then click the pencil icon to the right of the line item referenced in the error. Enter a more detailed Description of the package's contents. For example, instead of entering an Item Description of "shirt," enter "short sleeve shirt." Please refer to FedEx's web services guide for more details about item or commodity descriptions.
  3. Click Save after editing each line item.
  4. Repeat step 2 for additional line items referenced in the error.
  5. Once all edits are complete, click the Save & Close button in the Shipment Contents window.
  6. Try printing the label again.

UPDATED: March 09, 2024