Stamp or label prints to wrong user's or location's printer in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
Stamps or labels may print to the wrong printer if the same printer is listed in the system more than once and the incorrect instance is selected when printing.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Purpose statement
Issue
Stamps or shipping labels print to the wrong user's printer or a different location's printer.
Cause
The same printer may be listed under more than one Display Name (computer), and the incorrect instance is being selected when printing.
Resolution
Solution 1: Verify that the correct printer is selected
- Select Settings > My Devices.
- Verify that your computer name is listed under Display Name(By Location) and that the status in the Heartbeat column is Online. If it is not Online, go to Solution 3. If you are unsure of your computer name, contact your IT department for assistance.
- If your computer is listed under Display Name(By Location), verify that the printer you need is listed under that Display Name and that the printer status is either Online or Idle.
- If the printer is not listed under that Display Name, go to Solution 2.
- If the printer is listed but the status is Offline, go to Solution 2.
- If the printer is listed and the status is Online or Idle, try printing again. When selecting the printer from the Select Printer list, make sure that you are selecting it from under the correct Display Name (your computer name).
Solution 2: Make sure that your printer is installed, connected, and online
- Make sure that the printer is installed on your computer. If it is not, visit the manufacturer's website to download and install the latest print driver.
- In Windows, go to Settings > Devices > Printers and make sure that your printer is present and online.
- On Mac, go to Apple menu > System Settings > Printers & Scanners and make sure that your printer is present and online.
- Verify that the printer is turned on and awake.
- Verify that the printer is correctly connected to the computer.
- Verify the printer is listed under Settings > My Devices and that the status in the Heartbeat column is Online or Idle.
- Try printing the stamp or label again. When selecting the printer from the Select Printer list, make sure that you are selecting it from under the correct Display Name (your computer name).
Solution 3: Verify that DeviceHub is running
- There should be a DH (DeviceHub) icon in the Windows system tray (small icons near the clock) or Mac OS menu bar to show that it is running.
- If the icon is missing, find DeviceHub in your programs list and click on it to restart it.
- If the icon is present, right-click on it and choose Reconnect.
- Once the DH icon appears, hover your mouse over it to see the connection status and wait until it shows an Online status.
- When DeviceHub shows online, try printing again. When selecting the printer from the Select Printer list, make sure that you are selecting it from under the correct Display Name (your computer name).
UPDATED: December 12, 2023