USPS Large Envelope Label printed in PitneyShip, PitneyShip Pro, PitneyShip Enterprise, or ShipAccel does not have Tracking
If a USPS Large Envelope label does not have tracking, it is because First Class Mail is not eligible for free tracking.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise, ShipAccel
Issue
A USPS Large Envelope label printed in PitneyShip, PitneyShip Pro, PitneyShip Enterprise, or ShipAccel does not have a tracking barcode.
Cause
First-Class Mail® is not eligible for free tracking.
Resolution
To avoid this issue, when creating the shipping label, check the Over 3/4" thick box to ship the item as a USPS Ground Advantage instead of First-Class Mail.
UPDATED: June 02, 2025