"DeviceHub Registration failed" message when activating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise
If the message "DeviceHub Registration failed" appears, there may be an issue with your network blocking the activation, or DeviceHub may need to be uninstalled and reinstalled.
Products affected: PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
When activating DeviceHub, The message "DeviceHub Registration failed" or "Failed to register DeviceHub to your computer" appears.
Cause
There may be an issue with your network blocking activation of DeviceHub, or DeviceHub may need to be uninstalled and reinstalled.
Resolution
- Solution 1: Make sure DeviceHub is updated
- Solution 2: Uninstall and Reinstall DeviceHub
- Solution 3: Check the network specifications for DeviceHub
Solution 1: Make sure DeviceHub is updated
- Check for DeviceHub updates. See Updating DeviceHub in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise.
- Once updated, try updating DeviceHub again.
Solution 2: Uninstall and Reinstall DeviceHub
To uninstall DeviceHub, see:
To install DeviceHub, see:
Solution 3: Check the network specifications for DeviceHub
Review the DeviceHub Networking Requirements to ensure that your network allows for DeviceHub activation and communication. Contact your IT department if needed.
UPDATED: May 01, 2024