"Set up Payment Method" message in PitneyShip, PitneyShip Pro, or ShipAccel

The message "Set up Payment Method" means that the postage payment method has not been set up.

Products affected: PitneyShip®, PitneyShip® Pro, ShipAccel

Issue

The message "Set up Payment Method" appears in the USPS balance area in the upper right, in a trial expiration message, or in the Print button area on the Create Shipping Labels or Ship Orders screen.
Setup Payment Method message where postage balance should be  Setup Payment Method message where postage balance should be  Set up Payment Method button  

Cause

The postage payment method has not been set up yet.

Resolution

To add a credit card as your postage payment method:

  1. Click on the Set up Payment Method message.
  2. Add your credit card and click Submit.

If you need to add a Pitney Bowes Reserve Account or Purchase Power Account instead of a credit card, please contact us.

UPDATED: June 02, 2025