"Low Battery" or "Battery Urgent" message on the mailstation series

When you see the "Low Battery" or "Battery Urgent" message on the mailstation or mailstation2, you must first clear the message so that you can run mail and then create a case to replace your meter. It is not possible to replace the battery.
Products affected: mailstation™, mailstation2™

Issue

Alert: The USPS has discontinued all IBI meter technology, and many devices must be returned and withdrawn from service by the end of 2024. If your device is affected, new business rules will disrupt your mailing operation. Check Your Account to see if your device is affected and contact your Account Representative to migrate to a compliant solution.

Your meter displays the message "Low Battery" or "Battery Urgent". You cannot run mail.

Cause

Your meter's internal battery is nearing the end of its life.

Resolution

When you see the "Low Battery" or "Battery Urgent" message, you must first clear the message so that you can run mail and then create a case to replace your meter. It is not possible to replace the battery.

  1. Press the Clear/Back button to clear the message and run mail until the replacement meter arrives.
  2. If pressing the Clear/Back button does not clear your error message, restart your meter to clear the message.
    1. Unplug the power cord.
    2. Wait one full minute.
    3. Plug the power cord back in, ensuring that the meter plugs directly into a wall outlet.
  3. Create a Technical Support case to request a replacement meter.

UPDATED: September 25, 2024