"Print services has stopped" message on the SendPro C Lite, SendPro C, SendPro+, SendPro C Auto
If your device is displaying the message "Print services has stopped," your device software may be out of date. Contact Pitney Bowes technical support for assistance.
Products affected: SendPro® C Lite, SendPro® C, SendPro®+, SendPro® C Auto (8H00, 9H00)
Issue
When trying to print, the message "Print services has stopped" appears.
Cause
The device software may be out of date.
Resolution
This issue must be resolved by a Pitney Bowes representative. Please chat with us.
UPDATED: July 08, 2024