Resolving an overfilled postage meter

Learn how to resolve an overfilled mailstation, mailstation2, DM100i, DM125, DM200L, DM225, DM300C, DM400C, DM450C, DM475, DM Infinity, Connect+ 500W, Connect+ 1000, Connect+ 2000, Connect+ 3000, SendPro P1000, SendPro P1500, SendPro P2000, or SendPro P3000.
Products affected: mailstation™, mailstation2™, DM100®i, DM125™, DM200L™ DM225™, DM300C™, DM400C™, DM450C™, DM475™, DM Infinity™, Connect+® 500W, Connect+® 1000, Connect+® 2000, Connect+® 3000, SendPro™ P1000, SendPro™ P1500, SendPro™ P2000, SendPro™ P3000

Issue

Alert: The USPS has discontinued all IBI meter technology, and many devices must be returned and withdrawn from service by the end of 2024. If your device is affected, new business rules will disrupt your mailing operation. Check Your Account to see if your device is affected and contact your Account Representative to migrate to a compliant solution.

You refilled your meter for too much postage.

Cause

You chose a refill amount greater than intended, or the postage meter refilled more than once.

Resolution

If you accidentally overfilled your postage meter, please chat with us to resolve the issue.

Important: Do not request a refund to reverse a meter refill.

UPDATED: May 21, 2025