USPS commercial based pricing barcode or Aramex scan not read in SendSuite Arrival

Learn how to resolve United States Postal Service (USPS) commercial based pricing barcode or Aramex scan not being read or interpreted as a barcode in SendSuite Arrival.
Products affected: SendSuite® Arrival, J776 scanner, J782 scanner

Issue

When scanning a United States Postal Service (USPS) commercial based pricing or Aramex (ARMX) barcode, it is not interpreted as a barcode.

Cause

An F8 is being detected at the end of the barcode​, which is triggering the Arrival pop-up list function, which is associated with the F8 key.

Resolution

To resolve this issue, set the F8 key to do nothing in Arrival Setup:
  1. Open Arrival Setup and sign in:
    • Windows XP: Select Windows Start > Programs > Arrival > Arrival Setup.
    • Windows Vista, Windows 7: Select Windows Start > All Programs > Arrival > Arrival Setup.
  2. Select Miscellaneous > System Keyboard.
  3. In the Keyboard Mapping, select the F8 box.
  4. Select the Free key at the bottom of the pop-up window.
  5. Select OK in the top right of the pop-up window.
  6. Close and reopen Arrival.
  7. Rescan the barcode.
If the issue is not resolved, contact software support.

UPDATED: August 14, 2021