"Meter Locked Data Upload Required" appears on the screen on the SendPro P

Learn how to resolve the message "Meter Locked Data Upload Required" on the SendPro P.

Products affected: SendPro® P1000, SendPro® P1500, SendPro® P2000, SendPro® P3000

Issue

The message "Meter Locked Data Upload Required" appears.

Cause

If your franking machine has not connected to the Pitney Bowes Data Centre within 2 days you may see the error message "Meter Locked Data Upload Required" appear on the screen. This can occur after a software update that stores the account data on a different server.

Resolution

Solution 1: Upload data now

  • Click Upload Data Now. Allow between 2 and 3 minutes for the data to upload.

If you still get the "Meter Locked Data Upload Required" message, go to the next solution.

Solution 2: Verify that your system is connected to the internet

If you are unable to connect to the internet, ask your IT department to check the internet settings before you contact Pitney Bowes.

UPDATED: 13 June 2025