"Print Failed. Check your printer and try again" message when printing in SendPro Online, PitneyShip, PitneyShip Pro, and PitneyShip Enterprise
The message "Print Failed. Check your printer and try again" is caused by Microsoft Edge version 102.
Products affected: SendPro® Online, PitneyShip®, PitneyShip® Pro, PitneyShip® Enterprise
Issue
When printing from Microsoft Edge, the message "Print Failed. Check your printer and try again" appears.
Cause
The issue is specific to Microsoft Edge version 102.
Resolution
Solution 1: Do not use Print using system dialog
Do not use the Print using system dialog option (Ctrl+Shift+P). Print using the regular Print option (Ctrl+P) instead.
Solution 2: Use a different browser
If the error occurs when using Ctrl+P, try a different web browser.
UPDATED: December 12, 2023