"Error issuing certificate! - Policy cannot be created - name already exists" message in PitneyShip, PitneyShip Pro, or PitneyShip Enterprise

The message "Error issuing certificate! - Policy cannot be created - name already exists" occurs because DeviceHub is out of date and unable to update.
Products affected: PitneyShip™, PitneyShip™ Pro, PitneyShip™ Enterprise

Issue

The message "Error issuing certificate! - Policy cannot be created - name already exists" appears.

Cause

DeviceHub is out of date and unable to update.

Resolution

Solution 1: If using ZScaler, turn off ZScaler and try activating DeviceHub again

If you are not using Zscaler, go to solution 2.

  1. Turn off ZScaler.
  2. Go to Settings > My Devices.
  3. Select Activate DeviceHub.
  4. Click the Activate button again in the pop-up window.
  5. If successful, a new browser tab window will open with a "DeviceHub registered successfully!" message.
  6. Close the new browser tab.
  7. Select Settings > My Devices again.
  8. If your printers are still not displayed, click the Refresh button on the My Devices page.

If the issue is still not resolved, try solution 2.

Solution 2: Update configuration files and restart DeviceHub

Note: If you require assistance with these steps, contact your IT department.

Windows

  1. Right-click on the DH (DeviceHub) icon in the system tray (small icons near the clock) and select Exit.
  2. Locate the DeviceHub certificates files on the computer. They can be found by using the Windows Search option and pasting this folder path in search: C:\ProgramData\PB\devicehub\DeviceHub_v1\devicehubagent\config\certs
  3. Delete all certificates in this folder except for AmazonRootCA.pem and AmazonRootCA1.pem
  4. Now locate the DeviceHub configuration files on the computer. They can be found by using the Windows Search option and pasting this folder path in search: C:\ProgramData\PB\devicehub\DeviceHub_v1\devicehubagent\config
  5. Right-click on the dhaMQTConfig.json file and select Open with. Open this file using Noetpad.
  6. When the text file opens, locate isGenerated: in the text. If “isGenerated:” is followed by true, change true to false.
  7. Select File > Save.
  8. Find DeviceHub in your programs list and restart it.
  9. Activate DeviceHub. See solution 1 for the steps.

Mac

  1. Select the DeviceHub icon in the menu bar and select Exit.
  2. Locate and open the Macintosh HD.
  3. In the Search field, search for DeviceHub_mv1.
  4. Open the devicehubagent folder.
  5. Open the config folder.
  6. Open the Certs folder.
  7. Delete all certificates in this folder except for AmazonRootCA.pem and AmazonRootCA1.pem.
  8. Return to the devicehubagent folder, then open the config folder.
  9. Locate the dhaMQTConfig.json file and Control + click on the file name. Select Open With and select Text Edit.
  10. When the text file opens, locate isGenerated: in the text. If “isGenerated:” is followed by true, change true to false.
  11. Close the Text Edit window.
  12. Find DeviceHub in your programs list and restart it.
  13. Activate DeviceHub. See solution 1 for the steps.

If the issue is still not resolved, try solution 3.

Solution 3: Uninstall and reinstall DeviceHub

  1. Uninstall DeviceHub. See:
  2. Reinstall DeviceHub. See:

If the issue is still not resolved, try solution 4.

Solution 4: Make sure that your virus protection or network settings are not blocking DeviceHub

Check DeviceHub Networking Requirements and Technical Specifications to make sure that your virus protection or network settings are not blocking DeviceHub. Contact your IT department for assistance if needed.

UPDATED: December 21, 2023